
<!DOCTYPE html>
<html>
    <head>
        <meta charset="utf-8" />
        <meta name="viewport" content="width=1170" />
        <meta name="site" content="wkyc.com" />
        <link rel="stylesheet" href="/Views/dist/styles/modules.min.css?version=2.19.0" />
        <link rel="stylesheet" href="/Views/lib/jquery-ui/jquery-ui.min.css" />
        <link rel="stylesheet" href="/Views/lib/jquery-ui/jquery-ui.structure.min.css" />
        <link rel="stylesheet" href="/Views/lib/jquery-ui/jquery-ui.theme.min.css" />
        <!--[if IE]><link rel="shortcut icon" href="/content/favicon/WKYC.png?version=2.19.0"><![endif]-->
        <link rel="icon" href="/content/favicon/WKYC.png?version=2.19.0">
        <meta property="fb:app_id" content="145836432870387" />
        <meta property="og:site_name" content="WKYC" />
        <meta property="og:locale" content="en_US" />
        <meta itemprop="pageType" content="article" />
        <meta name="description" content="The Cleveland Browns suffered a 19-17 loss to the Buffalo Bills in the preseason home opener at FirstEnergy Stadium Friday night." />
            <script>
                var tealiumUrl = 'https://tags.tiqcdn.com/utag/tegna/wkyc-redesign-desktop/prod/utag.js';
                var utag_data = {
                    //Original Set
                    template_type: "", // ux name for page layout
                    page_type: "article",
                    division: "Broadcast",
                    site_type: "desktop",
                    page_url: window.location.href,
                    simplerreach_tags: "",
                    pathname: "https://www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319",
                    ad_slots: [],
                    gpt_network_code: "32805352/oh-cleveland-WKYC-B3330_DesktopTablet",
                    //Occurring in Both Sets
                    section: "sports",
                    subsection: "nfl",
                    topic: "browns",
                    subtopic: "",
                    content_type: "article",
                    category: "sports",
                    market: "Cleveland" + ", " + "OH",
                    //New Set
                    subcategory: "nfl",
                    keywords: "WKYC",
                    document_title: "WKYC.com",
                    canonical_url: "https://www.wkyc.com/article/sports/nfl/browns/live-updates-cleveland-browns-face-buffalo-bills-in-week-2-of-2018-nfl-preseason/95-585176319"
                };
            </script>
        <script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "Organization",
            "url": "https://www.wkyc.com",
            "logo": "https://www.wkyc.com/content/logos/mobile/wkyc.png",
            "sameAs": [
            "https://www.facebook.com/WKYC.Channel3",
            "https://twitter.com/@WKYC"
            ]
            }
        </script>
        <script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "WebSite",
            "url": "https://www.wkyc.com",
            "potentialAction": {
            "@type": "SearchAction",
            "target": "https://www.wkyc.com/search?q={search_term_string}",
            "query-input": "required name=search_term_string"
            }
            }
        </script>
            <meta itemprop="datePublished" content="8/17/2018 7:37:07 PM" />
            <meta itemprop="dateModified" content="8/18/2018 2:36:21 AM" />
            <meta itemprop="url" content="https://www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319" />
            <meta itemprop="magnet:custom" name="category" content="sports" />
            <meta property="og:url" content="https://www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319">
            <meta property="og:title" content="RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener">
            <meta property="og:description" content="The Cleveland Browns suffered a 19-17 loss to the Buffalo Bills in the preseason home opener at FirstEnergy Stadium Friday night.">
            <meta property="og:type" content="article" />
            <meta property="og:image" content="https://media.wkyc.com/assets/WKYC/images/582224320/582224320_1140x641.jpg" />
            <meta property="og:image:width" content="1140" />
            <meta property="og:image:height" content="641" />
            <meta property="og:article:published_time" content="8/17/2018 7:37:07 PM" />
            <meta name="twitter:title" content="RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener">
            <meta name="twitter:image:src" content="https://media.wkyc.com/assets/WKYC/images/582224320/582224320_360x203.jpg">
            <meta name="twitter:card" content="summary">
            <meta name="twitter:site" content="@WKYC">
            <meta name="twitter:description" content="The Cleveland Browns suffered a 19-17 loss to the Buffalo Bills in the preseason home opener at FirstEnergy Stadium Friday night.">
            <meta name="twitter:domain" content="www.wkyc.com">
            <link rel="canonical" href="https://www.wkyc.com/article/sports/nfl/browns/live-updates-cleveland-browns-face-buffalo-bills-in-week-2-of-2018-nfl-preseason/95-585176319" />
            <link rel="alternate" href="https://www.wkyc.com/mobile/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319" />
                <link rel="amphtml" href="https://www.wkyc.com/amp/article?section=sports&amp;subsection=nfl&amp;topic=browns&amp;headline=recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener&amp;contentId=95-585176319" />
            <script>
                if (window.utag_data) {
                    //Original Set
                    utag_data.video_included = "false";
                    utag_data.article_date = "8/17/2018 7:37:07 PM";
                    
                    utag_data.msj_tag = "";
                    if ("text" === "text")
                    {
                        utag_data.item_number = 1;
                    }
                    //Occurring in Both Sets
                    utag_data.asset_id = "585176319";
                    utag_data.article_keywords = "WKYC";
                    utag_data.content_title = "RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener";
                    utag_data.content_categories = "hue jackson,tyrod taylor,baker mayfield,cleveland browns,cleveland browns training camp,cleveland browns preseason,new york giants,metlife stadium,nfl preseason,nfl,national football league,matt florjancic";
                    //New Set
                    utag_data.article_byline = "Matthew Florjancic";
                    utag_data.topics_included = "false"; //whether related topics are present, may be able to remove since not using Klangoo

                    if ("" === "video")
                    {
                        utag_data.video_included = "true";  //if lead asset is video
                        utag_data.video_autoplay = "true";  //if lead asset is autoplay
                    }
                }
            </script>
            <title>RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener | wkyc.com</title>
                <style>
        .fc-pinned-header:after {
            background: #000000 url('/content/logos/dark/WKYC.png') calc(100% - 45px) 10px no-repeat;
            background-size: auto 25px;
            content: 'Ad blocker detected';
        }
        .fc-dialog-header:after {
            background: #000000 url('/content/logos/dark/WKYC.png') calc(100% - 20px) 10px no-repeat;
            background-size: auto 25px;
            content: 'Ad blocker detected';
        }
        </style>
    </head>
    <body id="page"
          class="page"
          data-model-siteid="95"
          data-model-gptid="oh-cleveland-WKYC-B3330_DesktopTablet"
          data-model-callletters="WKYC"
          data-model-primarydomain="wkyc.com"
          data-model-imageresizeurl="https://www.wkyc.com/img/resize/"
          data-model-imageresizeurl-wx="https://www.wkyc.com/img/wx/resize/"
          data-model-city="Cleveland"
          data-model-state="OH"
          data-model-fban="145836432870387"
          data-model-refresh="420"
          data-model-metadata="{
  &quot;title&quot;: &quot;WKYC.com&quot;,
  &quot;keywords&quot;: &quot;WKYC&quot;,
  &quot;contentType&quot;: &quot;article&quot;,
  &quot;pageType&quot;: &quot;article&quot;,
  &quot;continiousScrollSettings&quot;: {
    &quot;providers&quot;: [
      &quot;database&quot;,
      &quot;database&quot;,
      &quot;database&quot;,
      &quot;database&quot;,
      &quot;database&quot;
    ],
    &quot;default&quot;: &quot;database&quot;
  },
  &quot;platform&quot;: &quot;desktop&quot;
}"
          data-model-timezone="Eastern"
          data-model-twitterid="@WKYC"
          data-model-omnitureid="0"
          data-model-googleanalytics="455"
          data-model-tealiumgpt="446"
          data-model-version="2.19.0"
          data-model-closings="true"
          data-model-gptnetworkcode="32805352">
        <div id="fb-root"></div>
            <div class="page__desktop-header">
<div class="desktop-header desktop-header_collapsed_false">
    <div class="desktop-header__wrap">
        <div class="desktop-header__inner">
            <div class="desktop-header__toolbar">
<div class="toolbar">
    <div class="toolbar__live-indicator">
<div class="live-indicator live-indicator_collapsed_false">
                <div class="live-indicator__info live-indicator__info_visible_true">
                    <div class="live-indicator__cta">
                        <div class="live-indicator__watch-live">WATCH LIVE</div>
                        <div class="live-indicator__watch-time">On Air 5:55AM</div>
                    </div>
                </div>

</div>
    </div>
    <div class="toolbar__weather-summary">
<div class="weather-summary">
    <a class="weather-summary__link" data-tracking="weather-summary/weatherClicked" href="/weather">
        <div class="weather-summary__icon weather-icons weather-icons_icon_97"></div>
        <span class="weather-summary__current-temperature">70</span>
        <div class="weather-summary__location">Cleveland, OH</div>
        <div class="weather-summary__weather-conditions-container">
            <p class="weather-summary__weather-conditions">Cleveland Weather Summary: 70 degrees</p>
        </div>
        <!-- span class="weather-summary__details">
        <span class="weather-summary__high-low weather-summary__high-low_visible_true">
            <span class="weather-summary__high-low-icon"></span>
            <span class="weather-summary__high-low-label" title="high">H</span>
            <span class="weather-summary__high-low-temperature weather-summary__high">80</span>
            <span class="weather-summary__high-low-separator">/</span>
            <span class="weather-summary__high-low-label" title="low">L</span>
            <span class="weather-summary__high-low-temperature weather-summary__low">64</span>
        </span>
    </span -->
    </a>
</div>

    </div>
</div>
            </div>
            <div class="desktop-header__nav-button"><div class="desktop-header__nav-label">Menu</div></div>
            <div class="desktop-header__badges"></div>
            <a class="desktop-header__home-link desktop-header__home-link_visible_true" href="/" data-tracking="desktop-header/homeLinkClicked">
                <img class="desktop-header__logo" src="/content/logos/mobile/wkyc.png" />
            </a>
            <div class="desktop-header__article-title"></div>
        </div>
        <div class="desktop-header__progress desktop-header__progress_visible_false">
<progress class="progress" value="0"></progress>
        </div>
    </div>
    <div class="desktop-header__nav-wrapper">
        <div class="desktop-header__navigation desktop-header__navigation_visible_false desktop-header__navigation_collapsed_false">

<div class="navigation navigation_visible_false">
    <div class="navigation__main">
    <div class="navigation__main-inner">
        <div class="navigation__searchbox">
<div class="searchbox">
    <form class="searchbox__form" action="/search">
        <input class="searchbox__textbox" name="q" placeholder="Search"/>
        <button class="searchbox__submit" type="submit"></button>
    </form>
</div>
        </div>
        <div class="navigation__notification-container">
            <div class="navigation__notification">
                <div class="navigation__notification-title">WKYC Alert Center</div>
                <div class="navigation__notification-list">
                        <a class="navigation__notification-label navigation__notification-label_name_live-videos navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/live-video">Live Video</a>
                                            <a class="navigation__notification-label navigation__notification-label_name_breaking-news navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/breaking-news">Breaking<br />News</a>
                                            <a class="navigation__notification-label navigation__notification-label_name_weather navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/severe-weather">Weather</a>
                                                <a class="navigation__notification-label navigation__notification-label_name_closings navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/closings">Delays/<br />Closings</a>
                </div>
            </div>
        </div>
        <ul class="navigation__sponsored-list">
            <li class="navigation__sponsored-by">Sponsored by</li>
            <li class="navigation__sponsored-item">
                <a class="navigation__sponsored-link" data-tracking="navigation/sponsoredLinkClicked" href="/attheborder">
                    <img class="navigation__sponsored-image" src="https://cdn.tegna-media.com/wbir/assets/attheborder-352x52.png" alt="At the Border" />
                    <div class="navigation__sponsored-go-indicator"></div>
                </a>
            </li>
        </ul>
        <ul class="navigation__list">
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_news" href="/news" >News</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                            <ul class="navigation__sublist navigation__sublist_special_true navigation__sublist_visible_false">
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_local navigation__sublink_special_true" href="/local" >Local</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money navigation__sublink_special_true" href="/money" >Money</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment-news navigation__sublink_special_true" href="/entertainment" >Entertainment</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-nationnow navigation__sublink_special_true" href="/nation-now" >Nation Now</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-health navigation__sublink_special_true" href="/health" >Health</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life navigation__sublink_special_true" href="/life" >Life</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-investigations navigation__sublink_special_true" href="/investigative" >Investigative</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_community navigation__sublink_special_true" href="/community" >Community</a></li>
                            </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_weathertraffic" href="/weather/" >Weather &amp; Traffic</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather" href="/weather" >Current Weather</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather-radar" href="/radar" >Radar</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather" href="/10-day" >Hourly &amp; 10-Day</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather-closings" href="/closings" >Closings &amp; Delays</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather-closings" href="/textalerts" >Text Alerts</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather~weather-blog" href="/weather-features" >Weather Features</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather-environment" href="/environment" >Environment</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_tech~science" href="/space-science" >Earth and Space</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_traffic" href="/traffic" >Traffic</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_sports" href="/sports" >Sports</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports" href="/sports" >Latest Sports</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports-high-school" href="/hss" >High School</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports-nfl-browns" href="/browns" >Browns</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports-mlb-indians" href="/indians" >Indians</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports-nba-cavaliers" href="/cavaliers" >Cavaliers</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports-college-osu" href="/osu" >OSU Sports</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_features" href="/features" >Features</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-politics-rnc" href="/clevelandrising" >#ClevelandRising </a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-local-cleveland-rising" href="/risingwkyc" >#RisingWKYC</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~local~akron" href="/akron" >Akron</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~special-reports~at-the-border" href="/attheborder" >At the Border</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~local~canton" href="/canton" >Canton</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-local-contests" href="/contests" >Contests</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money~consumer~dealboss" href="/dealboss" >DEALBOSS</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_syndication-kin-community-food" href="/diy" >DIY</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment-television-programs-donovan-live" href="/donovan-live" >Donovan Live</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-education" href="/education" >Education</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life-events" href="/events" >Events</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_syndication-kin-community-food" href="/food" >Food</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life~holiday~halloween" href="/halloween" >Halloween</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_tech~science~girls-in-stem" href="/girlsinstem" >Girls in STEM</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~local~human-trafficking" href="/human-trafficking" >Human Trafficking</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life~events~incuya" href="/incuya-music-festival" >InCuya Music Festival</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life-family-if-my-parents-only-knew" href="/ifmyparentsonlyknew" >If My Parents Only Knew</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~special-reports~lebron-james-foundation" href="/lebron-james-foundation" >LeBron James Family Foundation</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment~television~liveonlakeside" href="/liveonlakeside" >Live on Lakeside</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money-magnify-money" href="/magnify-money" >Magnify Money</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life~pets" href="/pets" >Pets</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money-economy-possibleu" href="/possibleu" >Possible U</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money~markets~real-estate" href="/real-estate" >Real Estate</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life-food-recipes" href="/recipes" >Recipes</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment~music~rock-hall" href="/rockhall" >Rock &#39;n Roll Hall of Fame</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_local-northwest-ohio-see-possible" href="/seethepossible" >See the Possible</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink" href="https://www.shopdealboss.com/"  target=&quot;_blank&quot;>Shop</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_opinions-editorials-square-talk" href="/squaretalk" >Square Talk</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~local~unzipped" href="/unzipped" >Unzipped</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news" href="/votenow" >Vote Now</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-weird" href="/watercooler" >Water Cooler</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment-television-programs-we-the-people" href="/wethepeople" >We The People</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment-programs-wkyc-morning-show" href="/morning" >WKYC Morning Show</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~year-in-review" href="/yearinreview" >Year in Review</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_media" href="/video" >Media</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news" href="/video" >Video</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news" href="/gallery"  target=&quot;_blank&quot;>Photos</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_connect" href="/connect" >Connect</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/about-us" >About Us</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/advertise" >Advertise With Us</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/apps" >Apps</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us-contact-us" href="/contact-us" >Contact Us</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/internships" >Interships</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="https://www.jobs.net/jobs/tegna/en-us/all-jobs/?companyf=WKYC"  target=&quot;_blank&quot;>Jobs</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/tv-listings" >TV Listings</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="http://yourtake.wkyc.com" >Your Take</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/rss" >RSS Feeds</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
        </ul>
    </div>
    </div>
    <div class="navigation__footer">
        <div class="navigation__live-indicator">
        </div>
        <div class="navigation__social">
                <a href="https://www.facebook.com/WKYC.Channel3" target="_blank"><div class="navigation__icon navigation__icon_facebook"></div></a>

                <a href="https://twitter.com/intent/user?screen_name=@WKYC" target="_blank"><div class="navigation__icon navigation__icon_twitter"></div></a>

        </div>
        <div class="navigation__copyright">&copy; 2018 WKYC-TV. All Rights Reserved.</div>
    </div>

</div>
        </div>
    </div>
</div>
            </div>
        

        <div class="page__main page__main_stand-alone_false">
            <div class="page__modal-overlay"></div>
            <div class="page__grid">
                
<div class="grid">
            <div class="grid__section-group grid__section-group_theme_default">
                    <div class="grid__section grid__section_top_true grid__section_sticky_none grid__section_theme_default grid__section_theme-changed_false" data-theme="default">
                        <div class="grid__gutter">
                        </div>
                        <div class="grid__content grid__content_top_true grid__content_theme_default grid__content_theme-changed_false">
                            <div class="grid__main grid__main_sticky_none">
                                <div class="grid__cell grid__cell_columns_3" data-columns="12">
                                    <div class="grid__module grid__module_top_true grid__module_ready_true" data-count="0" data-module="notification" data-module-id="">
                                        <div class="grid__throbber"></div>
                                        <div class="grid__module-inner grid__module-inner_ready_true">
<div class="alert-bar alert-bar_visible_false">
    <div class="alert-bar__list">
    </div>
    <div class="alert-bar__controls">
        <div class="alert-bar__close-button"></div>
        <div class="alert-bar__arrows alert-bar__arrows_visible_false">
            <div class="alert-bar__arrow alert-bar__arrow_side_left"></div>
            <div class="alert-bar__arrow alert-bar__arrow_side_right"></div>
        </div>
    </div>
</div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                        <div class="grid__gutter">
                        </div>
                    </div>



                <div class="grid__section grid__section_sticky_left grid__section_theme_default grid__section_theme-changed_false grid__section_previous-theme_default grid__section_next-theme_default" data-theme="default" data-next-theme="default" data-previous-theme="default">
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                        </div>
                    </div>
                    <div class="grid__content grid__content_theme_default grid__content_theme-changed_false">
                                <div class="grid__sticky-column grid__sticky-column_side_left">
                                    <div class="grid__sticky-content" data-columns="4">
                                            <div class="grid__module grid__module_fast_false" data-track-movement="false" data-module="ad" data-module-id="2d60ed3a-b39c-4bca-9d4c-a1dbd607e57f">
      <div class="ad ad_border_true ad_position_article_atf" id="article_atf" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_atf&quot;,&quot;div&quot;:&quot;article_atf&quot;,&quot;sizes&quot;:[[300,250],[300,600]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;585176319&quot;],&quot;main_front&quot;:[&quot;false&quot;],&quot;pgtype&quot;:[&quot;article&quot;]}}"></div>

                                            </div>
                                            <div class="grid__module grid__module_fast_false" data-track-movement="false" data-module="docked-video-slot" data-module-id="d7dfc4a5-4f84-4c70-afda-726d3fc4168f">
<div class="docked-video-slot">
    <div class="docked-video-slot__inner"></div>
</div>
                                            </div>
                                    </div>
                                </div>
                        <div class="grid__main grid__main_sticky_left">
                                        <div class="grid__cell grid__cell_columns_2" data-starting-column="5" data-columns="8">

                                                <div class="grid__module grid__module_ready_true" data-track-movement="true" data-count="0" data-module="articles" data-module-id="f3f37245-83dd-402c-b229-87b7f61c4033">
                                                    <div class="grid__throbber"></div>
                                                    <div class="grid__module-inner grid__module-inner_ready_true">
<div class="article"
        data-dock-context-for="sharing title"
        data-model-title="RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener"
        data-model-article="585176319"
        data-model-section="sports"
        data-model-subsection="nfl"
        data-model-topic="browns"
        data-model-subtopic=""
        data-model-gptId="446" 
        data-model-omnitureId="0" 
        data-model-comscoreId="1" 
        data-model-url="www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319" data-model-id="585176319" 
        data-model-gpt="32805352/oh-cleveland-WKYC-B3330_DesktopTablet"
        data-model-hasvideo="false"
        data-model-iscontinuousscroll="false"
        data-model-categories="news, local, sports, home, nfl, browns, facebook-instant"
        data-sharing-target="true"
        data-sharing-title="RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener"
        data-sharing-url="www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319"
        
        data-model-author=""
        data-model-keywords="[
  &quot;hue jackson&quot;,
  &quot;tyrod taylor&quot;,
  &quot;baker mayfield&quot;,
  &quot;cleveland browns&quot;,
  &quot;cleveland browns training camp&quot;,
  &quot;cleveland browns preseason&quot;,
  &quot;new york giants&quot;,
  &quot;metlife stadium&quot;,
  &quot;nfl preseason&quot;,
  &quot;nfl&quot;,
  &quot;national football league&quot;,
  &quot;matt florjancic&quot;
]"
>
    <div class="article__article-story">
    <div class="article-story">
        <div class="article-story__lead-asset">
<div class="article-story__image-container">
                <div class="article-story__ratio-enforcer">
                    <div class="article-story__ratio-enforced">
                        <img data-asset-fallback="default" class="article-story__image" src="https://media.wkyc.com/assets/WKYC/images/582224320/582224320_750x422.jpg" alt="The Cleveland Browns suffered a 19-17 loss to the Buffalo Bills in the preseason home opener at FirstEnergy Stadium Friday night." />
                    </div>
                </div>
            </div>
        </div>
        
    


        <h2 class="article-story__category article-story__category_section_nfl"><a data-tracking="article-story/categoryLinkClicked/browns" class="article-story__category-link" href="/section/sports/nfl/browns">BROWNS</a></h2>


            <div class="article-story__lead-asset-caption">
                    <div class="article-story__lead-asset-credit">
                        Photo: Ken Blaze
                    </div>
            </div>
        
        <h1 class="article-story__headline grid__scroll-hook" data-scroll-hook-name="article-story__headline">RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener</h1>
        <div class="article-story__abstract">
            The Cleveland Browns suffered a 19-17 loss to the Buffalo Bills in the preseason home opener at FirstEnergy Stadium Friday night.
        </div>
        
    </div>
    <script type="application/ld+json">
        {
            "@context": "http://schema.org",
            "@type": "NewsArticle",
            "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319"
            },
            "headline": "RECAP: Cleveland Browns fall to Buffalo Bills, 19-17, in preseason home opener",

                
                    "image" : ["https://media.wkyc.com/assets/WKYC/images/582224320/582224320_750x422.jpg"],
                

            "datePublished": "8/17/2018 7:37:07 PM",
            "dateModified": "8/18/2018 2:36:21 AM",
            "author": {
                "@type": "Person",
                "name": ""
            },
            "publisher": {
                "@type": "Organization",
                "name": "WKYC",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://www.wkyc.com/content/logos/amp/wkyc.png",
                    "width": 340,
                    "height": 60
                }
            },
            "description": "The Cleveland Browns suffered a 19-17 loss to the Buffalo Bills in the preseason home opener at FirstEnergy Stadium Friday night."
        }
</script>

    </div>
    <div class="article__story-highlights">

<div class="story-highlights">
</div>
    </div>
    <div class="article__author" data-grid-gutter-top="right">
    <div class="author">
        <div class="author__container">
            <div class="author__data">
                <div class="author__item">
                    <span class="author__tag">Author: </span>
                    <span class="author__name">
Matthew Florjancic
                    </span>
                </div>
                <div class="author__item">
                    <span class="author__tag">Published: </span>
                            <span class="author__date">
                                3:37 PM EDT August 17, 2018
                            </span>
                </div>
                <div class="author__item">
                    <span class="author__tag">Updated: </span>
                        <span class="author__date">
                            10:36 PM EDT August 17, 2018
                        </span>
                </div>
            </div>
        </div>
    </div>

    </div>
    <div class="article__article-body">

    <div class="article-body">
        <div class="text">

                        <p><strong>10:33 p.m.-BUFFALO BILLS TOP CLEVELAND BROWNS, 19-17, IN PRESEASON ACTION</strong></p><p>CLEVELAND -- All good things must come to an end, and for the Cleveland Browns, that was their preseason winning streak.</p><p>Winners of five consecutive preseason games, the Browns allowed 13 straight points to the Buffalo Bills over the second and third quarters and suffered a 19-17 loss in their preseason home opener at FirstEnergy Stadium in Cleveland Friday night.</p>      <div class="ad ad_border_true ad_position_article_mid1" id="article_mid1_0" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_mid1&quot;,&quot;div&quot;:&quot;article_mid1_0&quot;,&quot;sizes&quot;:[[300,250],[1,1],[750,570]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;585176319&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;]}}"></div>
<p>Buffalo rookie quarterback Josh Allen completed nine of his 13 attempts for 60 yards with one touchdown, and Nathan Peterman completed the comeback victory with a 35-yard scoring pass to tight end Nick O’Leary in the fourth quarter.</p><p>Quarterback play was a strength for the Browns in their win over the New York Giants last Thursday, but Tyrod Taylor and Baker Mayfield combined to complete 11 of their 20 attempts for 97 yards with no touchdowns in the loss to Buffalo.</p><p>While the passing game was inconsistent against the Bills, the rushing attack accounted for 164 yards on 32 carries after totaling just 50 yards on 33 attempts against the Giants.</p>
<div class="newsletter-signup">
    <div class="newsletter-signup__container newsletter-signup__hidden">
        <div class="newsletter-signup__main-label newsletter-signup__lightText" style="background-color:#ae2128">
            <div class="newsletter-signup__main-label-text newsletter-signup__awaiting">
                Sign up for the daily Top 3 Newsletter
            </div>
            <div class="newsletter-signup__main-label-text newsletter-signup__complete">
                Sign up for the daily Top 3 Newsletter
            </div>
            <div class="newsletter-signup__main-label-text newsletter-signup__error">
                Something went wrong.
            </div>
        </div>
        <div class="newsletter-signup__content">
            <div class="newsletter-signup__instructions">
                <div class="newsletter-signup__instructions-text newsletter-signup__awaiting">
                    This email will be delivered to your inbox once a day in the morning.
                </div>
                <div class="newsletter-signup__instructions-text newsletter-signup__complete">
                    Thank you for signing up for the Top 3 Newsletter.
                </div>
                <div class="newsletter-signup__instructions-text newsletter-signup__error">
                    Please try again later.
                </div>
            </div>
            <div class="newsletter-signup__form-container newsletter-signup__awaiting">
                <form class="newsletter-signup__form">
                    <div class="newsletter-signup__form-email-wrap">
                        <input type="text" placeholder="ENTER EMAIL HERE " name="email" class="newsletter-signup__form-email" /><br />
                    </div>
                                                            <button type="submit" class="newsletter-signup__submit newsletter-signup__lightText newsletter-signup__lightArrow" style="background-color:#ae2128"><span class="newsletter-signup__submit__text">Submit</span></button>
                    <div class="newsletter-signup__form-email-error"></div>
                    <input type="hidden" name="siteId" value="95" />
                    <input type="hidden" name="newsletterId" value="1fef2b83fa23c42a33257e728cc42cb1" />
                </form>
            </div>
        </div>
    </div>
</div><p>Starter Carlos Hyde rushed for a game-best 64 yards and one touchdown on nine carries, while rookie Nick Chubb registered 53 yards and one score on 11 attempts.</p>                                    <div data-module="media-gallery" data-track-off-screen="true" data-track-movement="true">


<div class="media-gallery"
     data-model-id="585289756"
     data-model-section="sports"
     data-model-subsection="nfl"
     data-model-topic="browns"
     data-model-subtopic=""
     data-model-url="/gallery/sports/nfl/browns/photos-cleveland-browns-battle-buffalo-bills-in-preseason-action/95-585289756"
     data-model-count="10"
     data-model-assetid="585289756"
     data-model-index="0"
     data-model-targeting="{&quot;pgid&quot;: [&quot;585289756&quot;],&quot;pgtype&quot;: [&quot;&quot;],&quot;strnativekey&quot;: [&quot;cTjReTE4PFTtiwNcLwExqbY9&quot;],&quot;strnativekey&quot;: [&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;]}"
     data-model-autofullscreen="false"
     data-track-off-screen="true">
    <div class="media-gallery__main">
        <div class="media-gallery__title">PHOTOS: Cleveland Browns battle Buffalo Bills in preseason action</div>
        <div class="media-gallery__fullscreen-toggle"></div>
        <div class="media-gallery__slider-container">
            <div class="media-gallery__slider-arrows">
                <div class="media-gallery__slider-nav media-gallery__slider-nav_direction_previous">
                    <div class="media-gallery__slider-arrow"></div>
                </div>
                <div class="media-gallery__slider-nav media-gallery__slider-nav_direction_next">
                    <div class="media-gallery__slider-arrow"></div>
                </div>
            </div>
            <div class="media-gallery__fake-slider">
                <div class="media-gallery__ratio-enforcer">
                    <div class="media-gallery__ratio-enforced">
                        <img class="media-gallery__fake-slide" src="https://media.wkyc.com/assets/WKYC/images/585291426/585291426_1140x641.jpg" />
                    </div>
                </div>
            </div>
            <div class="media-gallery__slider">
                    <div class="media-gallery__slide"
                         data-index="0"
                         data-model-assetid="585291426"
                         data-model-caption="Cleveland Browns running back Carlos Hyde, right, celebrates his first-quarter touchdown with running back Duke Johnson (29) and center JC Tretter (64) against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-TD%20Celebration_1534555549438.jpg_17361983_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291426/585291426_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="1"
                         data-model-assetid="585291486"
                         data-model-caption="Cleveland Browns defensive tackle Larry Ogunjobi (65) tackles Buffalo Bills running back LeSean McCoy (25) during the first quarter at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Larry%20Ogunjobi-Bills_1534555571248.jpg_17361987_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291486/585291486_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="2"
                         data-model-assetid="585307941"
                         data-model-caption="Cleveland Browns quarterback Baker Mayfield warms up before a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Baker%20Mayfield-Bills_1534558787762.jpg_17362538_ver1.0.jpg"
                         data-model-credit="Joe Robbins">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585307941/585307941_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="3"
                         data-model-assetid="585307932"
                         data-model-caption="Cleveland Browns running back Duke Johnson Jr. delivers a stiff arm to a defender in the first quarter of a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Duke%20Johnson-Bills2_1534558787620.jpg_17362537_ver1.0.jpg"
                         data-model-credit="Joe Robbins">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585307932/585307932_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="4"
                         data-model-assetid="585299148"
                         data-model-caption="Cleveland Browns head coach Hue Jackson yells at wide receiver Jeff Janis (13) after a penalty during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Hue%20Jackson-Jeff%20Janis_1534557484595.jpg_17362628_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585299148/585299148_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="5"
                         data-model-assetid="585299157"
                         data-model-caption="Cleveland Browns running back Duke Johnson (29) rushes with the ball during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Duke%20Johnson-Bills_1534557485257.jpg_17362629_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585299157/585299157_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="6"
                         data-model-assetid="585291435"
                         data-model-caption="Cleveland Browns running back Carlos Hyde (34) scores a touchdown as Buffalo Bills cornerback Tre&#39;Davious White (27) and defensive end Jerry Hughes (55) pursue during the first quarter at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-TD_1534555549860.jpg_17361984_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291435/585291435_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="7"
                         data-model-assetid="585291502"
                         data-model-caption="Cleveland Browns head coach Hue Jackson walks away from the team as the players huddle before the game against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Hue%20Jackson-Bills_1534555577063.jpg_17361988_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291502/585291502_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="8"
                         data-model-assetid="585291469"
                         data-model-caption="Cleveland Browns running back Carlos Hyde (34) delivers a stiff arm against Buffalo Bills defensive back Jordan Poyer (21) at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-Stiff%20Arm_1534555563538.jpg_17361986_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291469/585291469_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="9"
                         data-model-assetid="585291450"
                         data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws a pass during the first quarter against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                         data-model-url="http://content.wkyc.com/photo/2018/08/17/Tyrod%20Taylor-Bills_1534555556553.jpg_17361985_ver1.0.jpg"
                         data-model-credit="Ken Blaze">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291450/585291450_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
            </div>
        </div>
    </div>
    <div class="media-gallery__secondary">
        <div class="media-gallery__meta">
                <div class="media-gallery__meta-item media-gallery__meta-item_current_true"
                     data-index="0"
                     data-model-assetid="585291426"
                     data-model-caption="Cleveland Browns running back Carlos Hyde, right, celebrates his first-quarter touchdown with running back Duke Johnson (29) and center JC Tretter (64) against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-TD%20Celebration_1534555549438.jpg_17361983_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">01</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns running back Carlos Hyde, right, celebrates his first-quarter touchdown with running back Duke Johnson (29) and center JC Tretter (64) against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="1"
                     data-model-assetid="585291486"
                     data-model-caption="Cleveland Browns defensive tackle Larry Ogunjobi (65) tackles Buffalo Bills running back LeSean McCoy (25) during the first quarter at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Larry%20Ogunjobi-Bills_1534555571248.jpg_17361987_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">02</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns defensive tackle Larry Ogunjobi (65) tackles Buffalo Bills running back LeSean McCoy (25) during the first quarter at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="2"
                     data-model-assetid="585307941"
                     data-model-caption="Cleveland Browns quarterback Baker Mayfield warms up before a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Baker%20Mayfield-Bills_1534558787762.jpg_17362538_ver1.0.jpg"
                     data-model-credit="Joe Robbins">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">03</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Baker Mayfield warms up before a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="3"
                     data-model-assetid="585307932"
                     data-model-caption="Cleveland Browns running back Duke Johnson Jr. delivers a stiff arm to a defender in the first quarter of a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Duke%20Johnson-Bills2_1534558787620.jpg_17362537_ver1.0.jpg"
                     data-model-credit="Joe Robbins">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">04</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns running back Duke Johnson Jr. delivers a stiff arm to a defender in the first quarter of a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="4"
                     data-model-assetid="585299148"
                     data-model-caption="Cleveland Browns head coach Hue Jackson yells at wide receiver Jeff Janis (13) after a penalty during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Hue%20Jackson-Jeff%20Janis_1534557484595.jpg_17362628_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">05</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns head coach Hue Jackson yells at wide receiver Jeff Janis (13) after a penalty during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="5"
                     data-model-assetid="585299157"
                     data-model-caption="Cleveland Browns running back Duke Johnson (29) rushes with the ball during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Duke%20Johnson-Bills_1534557485257.jpg_17362629_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">06</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns running back Duke Johnson (29) rushes with the ball during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="6"
                     data-model-assetid="585291435"
                     data-model-caption="Cleveland Browns running back Carlos Hyde (34) scores a touchdown as Buffalo Bills cornerback Tre&#39;Davious White (27) and defensive end Jerry Hughes (55) pursue during the first quarter at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-TD_1534555549860.jpg_17361984_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">07</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns running back Carlos Hyde (34) scores a touchdown as Buffalo Bills cornerback Tre&#39;Davious White (27) and defensive end Jerry Hughes (55) pursue during the first quarter at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="7"
                     data-model-assetid="585291502"
                     data-model-caption="Cleveland Browns head coach Hue Jackson walks away from the team as the players huddle before the game against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Hue%20Jackson-Bills_1534555577063.jpg_17361988_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">08</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns head coach Hue Jackson walks away from the team as the players huddle before the game against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="8"
                     data-model-assetid="585291469"
                     data-model-caption="Cleveland Browns running back Carlos Hyde (34) delivers a stiff arm against Buffalo Bills defensive back Jordan Poyer (21) at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-Stiff%20Arm_1534555563538.jpg_17361986_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">09</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns running back Carlos Hyde (34) delivers a stiff arm against Buffalo Bills defensive back Jordan Poyer (21) at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="9"
                     data-model-assetid="585291450"
                     data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws a pass during the first quarter against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                     data-model-url="http://content.wkyc.com/photo/2018/08/17/Tyrod%20Taylor-Bills_1534555556553.jpg_17361985_ver1.0.jpg"
                     data-model-credit="Ken Blaze">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">10</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Tyrod Taylor (5) throws a pass during the first quarter against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
        </div>
        <div class="media-gallery__thumbstrip-container">
            <div class="media-gallery__thumbstrip-arrows">
                <div class="media-gallery__thumbstrip-nav media-gallery__thumbstrip-nav_direction_previous">
                    <div class="media-gallery__thumbstrip-arrow"></div>
                </div>
                <div class="media-gallery__thumbstrip-nav media-gallery__thumbstrip-nav_direction_next">
                    <div class="media-gallery__thumbstrip-arrow"></div>
                </div>
            </div>
            <div class="media-gallery__thumbstrip">
                <div class="media-gallery__thumbstrip-mask">
                    <div class="media-gallery__thumbstrip-slider">
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="0"
                                 data-model-assetid="585291426"
                                 data-model-caption="Cleveland Browns running back Carlos Hyde, right, celebrates his first-quarter touchdown with running back Duke Johnson (29) and center JC Tretter (64) against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-TD%20Celebration_1534555549438.jpg_17361983_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_true"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291426/585291426_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="1"
                                 data-model-assetid="585291486"
                                 data-model-caption="Cleveland Browns defensive tackle Larry Ogunjobi (65) tackles Buffalo Bills running back LeSean McCoy (25) during the first quarter at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Larry%20Ogunjobi-Bills_1534555571248.jpg_17361987_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291486/585291486_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="2"
                                 data-model-assetid="585307941"
                                 data-model-caption="Cleveland Browns quarterback Baker Mayfield warms up before a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Baker%20Mayfield-Bills_1534558787762.jpg_17362538_ver1.0.jpg"
                                 data-model-credit="Joe Robbins">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585307941/585307941_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="3"
                                 data-model-assetid="585307932"
                                 data-model-caption="Cleveland Browns running back Duke Johnson Jr. delivers a stiff arm to a defender in the first quarter of a preseason game against the Buffalo Bills at FirstEnergy Stadium in Cleveland, Ohio."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Duke%20Johnson-Bills2_1534558787620.jpg_17362537_ver1.0.jpg"
                                 data-model-credit="Joe Robbins">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585307932/585307932_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="4"
                                 data-model-assetid="585299148"
                                 data-model-caption="Cleveland Browns head coach Hue Jackson yells at wide receiver Jeff Janis (13) after a penalty during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Hue%20Jackson-Jeff%20Janis_1534557484595.jpg_17362628_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585299148/585299148_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="5"
                                 data-model-assetid="585299157"
                                 data-model-caption="Cleveland Browns running back Duke Johnson (29) rushes with the ball during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Duke%20Johnson-Bills_1534557485257.jpg_17362629_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585299157/585299157_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="6"
                                 data-model-assetid="585291435"
                                 data-model-caption="Cleveland Browns running back Carlos Hyde (34) scores a touchdown as Buffalo Bills cornerback Tre&#39;Davious White (27) and defensive end Jerry Hughes (55) pursue during the first quarter at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-TD_1534555549860.jpg_17361984_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291435/585291435_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="7"
                                 data-model-assetid="585291502"
                                 data-model-caption="Cleveland Browns head coach Hue Jackson walks away from the team as the players huddle before the game against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Hue%20Jackson-Bills_1534555577063.jpg_17361988_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291502/585291502_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="8"
                                 data-model-assetid="585291469"
                                 data-model-caption="Cleveland Browns running back Carlos Hyde (34) delivers a stiff arm against Buffalo Bills defensive back Jordan Poyer (21) at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Carlos%20Hyde-Stiff%20Arm_1534555563538.jpg_17361986_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291469/585291469_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="9"
                                 data-model-assetid="585291450"
                                 data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws a pass during the first quarter against the Buffalo Bills at FirstEnergy Stadium in Cleveland."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/17/Tyrod%20Taylor-Bills_1534555556553.jpg_17361985_ver1.0.jpg"
                                 data-model-credit="Ken Blaze">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291450/585291450_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="media-gallery__ad">
        </div>
    </div>
</div>
                                    </div>
<p><strong>10:06 p.m.-BILLS STRIKE BACK, RETAKE LEAD OVER BROWNS</strong></p><p>CLEVELAND -- Nathan Peterman’s 35-yard touchdown pass to tight end Nick O’Leary gave the Buffalo Bills a 19-17 lead over the Cleveland Browns with 9:02 to play in the fourth quarter of their preseason matchup at FirstEnergy Stadium in Cleveland Friday night.</p><p>Although the point-after-touchdown attempt failed, the Bills retook the lead with their seven-play, 75-yard scoring drive that they needed just 3:31 to complete with the touchdown pass.</p><p>Peterman’s 35-yard touchdown throw came on third-and-seven, as he found O’Leary open on the right side of the field, and the third-year tight end hustled his way into the end zone for the go-ahead score.</p><div class="image">
    <div class="image__aspect-ratio-enforcer">
        <div class="image__aspect-ratio-enforced" data-aspect-ratio>
            <img class="image__image" data-asset-fallback="default" data-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291486/585291486_750x422.jpg" alt="Larry Ogunjobi-Bills_1534555571248.jpg.jpg" />
        </div>
    </div>
</div>
    <div class="image__caption">Cleveland Browns defensive tackle Larry Ogunjobi (65) tackles Buffalo Bills running back LeSean McCoy (25) during the first quarter at FirstEnergy Stadium in Cleveland.</div>
    <div class="image__credit">Ken Blaze</div>
<p><strong>9:59 p.m.-NICK CHUBB RUSHES FOR GO-AHEAD TOUCHDOWN</strong></p><p>CLEVELAND -- Cleveland Browns running back Nick Chubb finished off a scoring drive the only way he knew how after rushing the offense down to the Buffalo Bills’ one-yard line, and that was with a straight-ahead inside run into the end zone.</p>      <div class="ad ad_border_true ad_position_article_mid2" id="article_mid2_0" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_mid2&quot;,&quot;div&quot;:&quot;article_mid2_0&quot;,&quot;sizes&quot;:[[300,250],[1,1]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;585176319&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;]}}"></div>
<p>Chubb’s scoring run and the ensuing extra point gave the Browns a 17-13 lead over the Bills with 12:33 to play in regulation and punctuated a nine-play, 65-yard drive that took 2:59 off of the game clock.</p><div class="article__embed">
    <blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">We 👀 you, <a href="https://twitter.com/NickChubb21?ref_src=twsrc%5Etfw">@nickchubb21</a>!<br><br>Touchdown, <a href="https://twitter.com/hashtag/Browns?src=hash&ref_src=twsrc%5Etfw">#Browns</a>! <a href="https://t.co/6T5wD6sdKc">pic.twitter.com/6T5wD6sdKc</a></p>— Cleveland Browns (@Browns) <a href="https://twitter.com/Browns/status/1030635697537875968?ref_src=twsrc%5Etfw">August 18, 2018</a></blockquote><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div><p>Earlier in the drive, Chubb took a handoff from quarterback Baker Mayfield, hustled through a gap opened up by blocks from the offensive line and sprinted toward the pylon in the left front corner of the end zone. However, Chubb was ruled out inside the one-yard line and was stopped for no gain on the next play.</p><p>Then, after having a touchdown pass from Mayfield to wide receiver Derrick Willies overturned on replay, the Browns went back to Chubb and the first-year rusher finished what he started with the touchdown run.</p><div class="image">
    <div class="image__aspect-ratio-enforcer">
        <div class="image__aspect-ratio-enforced" data-aspect-ratio>
            <img class="image__image" data-asset-fallback="default" data-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291469/585291469_750x422.jpg" alt="Carlos Hyde-Stiff Arm_1534555563538.jpg.jpg" />
        </div>
    </div>
</div>
    <div class="image__caption">Cleveland Browns running back Carlos Hyde (34) delivers a stiff arm against Buffalo Bills defensive back Jordan Poyer (21) at FirstEnergy Stadium in Cleveland.</div>
    <div class="image__credit">Ken Blaze</div>
<p><strong>9:35 p.m.-BROWNS DRAW TO WITHIN FIELD GOAL OF BILLS</strong></p><p>CLEVELAND -- An offensive pass interference penalty took a touchdown off of the scoreboard, but the Cleveland Browns still converted a field goal attempt and drew to within three points of the Buffalo Bills with 2:16 to play in the third quarter of their preseason home opener at FirstEnergy Stadium Friday night.</p><p>A 31-yard field goal from kicker Ross Martin capped off an 11-play, 51-yard drive that took nearly six minutes off of the clock and cut Buffalo’s lead down to 13-10 late in the third quarter.</p><p>Two plays before the field goal, it appeared the Browns would attempt the go-ahead a point-after-touchdown try when rookie quarterback Baker Mayfield threw a touchdown pass to wide receiver Derrick Willies, but tight end Devon Cajuste was flagged for offensive pass interference.</p><p>Cajuste’s penalty cost the Browns the six points and 10 yards on top of it, which backed up the offense to Buffalo’s 12-yard line. Subsequently, Mayfield’s next attempt to Willies fell incomplete short of the goal line and brought on Martin for the try.</p><div class="image">
    <div class="image__aspect-ratio-enforcer">
        <div class="image__aspect-ratio-enforced" data-aspect-ratio>
            <img class="image__image" data-asset-fallback="default" data-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291450/585291450_750x422.jpg" alt="Tyrod Taylor-Bills_1534555556553.jpg.jpg" />
        </div>
    </div>
</div>
    <div class="image__caption">Cleveland Browns quarterback Tyrod Taylor (5) throws a pass during the first quarter against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
    <div class="image__credit">Ken Blaze</div>
<p><strong>9:18 p.m.-BILLS ADD ONTO LEAD OVER BROWNS</strong></p><p>CLEVELAND -- The Buffalo Bills began the second half in the same way they ended the first, with a field goal.</p><p>After their six-play, 21-yard drive stalled at the Cleveland 43-yard line, Bills kicker Stephen Hauschka converted a 53-yard field goal attempt, which gave Buffalo a 13-7 lead over the Browns with 10:51 remaining in the third quarter of their preseason game at FirstEnergy Stadium.</p>      <div class="ad ad_border_true ad_position_article_mid3" id="article_mid3_0" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_mid3&quot;,&quot;div&quot;:&quot;article_mid3_0&quot;,&quot;sizes&quot;:[[300,250]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;585176319&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;cTjReTE4PFTtiwNcLwExqbY9&quot;]}}"></div>
<p>Earlier in the drive, Bills rookie quarterback Josh Allen flared a pass out to the left of the formation to former Browns wide receiver Corey Coleman, who gained seven yards on the catch just 12 days after being dealt from Cleveland to Buffalo for a seventh-round pick in the 2020 NFL Draft.</p><div class="image">
    <div class="image__aspect-ratio-enforcer">
        <div class="image__aspect-ratio-enforced" data-aspect-ratio>
            <img class="image__image" data-asset-fallback="default" data-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291502/585291502_750x422.jpg" alt="Hue Jackson-Bills_1534555577063.jpg.jpg" />
        </div>
    </div>
</div>
    <div class="image__caption">Cleveland Browns head coach Hue Jackson walks away from the team as the players huddle before the game against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
    <div class="image__credit">Ken Blaze</div>
<p><strong>8:52 p.m.-BILLS TAKE LEAD ON LATE FIELD GOAL</strong></p><p>CLEVELAND -- Buffalo Bills rookie quarterback Josh Allen executed his second consecutive scoring drive late in the first half in preseason action against the Cleveland Browns at FirstEnergy Stadium in Cleveland Friday night.</p><p>After leading a touchdown drive on his first possession of the game, Allen engineered an eight-play, 26-yard scoring drive that veteran kicker Stephen Hauschka punctuated with a 33-yard field goal, which gave Buffalo a 10-7 lead over Cleveland with three seconds remaining in the first half.</p><p>The Browns nearly forced a turnover when the Bills faced a second-and-two from the Cleveland 22-yard line, as running back Travaris Cadet fumbled the football after being hit by backup linebacker Justin Currie at the line of scrimmage. However, Buffalo guard John Miller saved the possession when he recovered the loose ball at the 21-yard line.</p><p>On the next play, Allen took the third-and-one snap out of the shotgun formation and hustled around right end for a six-yard gain and Buffalo first down from the Cleveland 15-yard line.</p><div class="image">
    <div class="image__aspect-ratio-enforcer">
        <div class="image__aspect-ratio-enforced" data-aspect-ratio>
            <img class="image__image" data-asset-fallback="default" data-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585299148/585299148_750x422.jpg" alt="Hue Jackson-Jeff Janis_1534557484595.jpg.jpg" />
        </div>
    </div>
</div>
    <div class="image__caption">Cleveland Browns head coach Hue Jackson yells at wide receiver Jeff Janis (13) after a penalty during the first half against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
    <div class="image__credit">Ken Blaze</div>
<p><strong>8:38 p.m.-BILLS DRAW EVEN WITH BROWNS</strong></p><p>CLEVELAND -- The Buffalo Bills made the switch to the second-team offense, and that resulted in their first extended drive of the preseason home opener for the Cleveland Browns at FirstEnergy Stadium, a possession that finished in the end zone.</p><p>Despite a heavy rush on third-and-goal from inside the five-yard line, rookie quarterback Josh Allen moved around in the pocket long enough for wide receiver Rod Streater to shake loose from a Browns defensive back and haul in the touchdown pass at the back of the end zone.</p><div class="article__embed">
    <blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">17 to 81 for 6!<a href="https://twitter.com/hashtag/BUFvsCLE?src=hash&ref_src=twsrc%5Etfw">#BUFvsCLE</a> <a href="https://twitter.com/hashtag/GoBills?src=hash&ref_src=twsrc%5Etfw">#GoBills</a> <a href="https://t.co/tKvsJgLCHW">pic.twitter.com/tKvsJgLCHW</a></p>— Buffalo Bills (@buffalobills) <a href="https://twitter.com/buffalobills/status/1030615759318175746?ref_src=twsrc%5Etfw">August 18, 2018</a></blockquote><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div><p>The point-after-touchdown drew the Browns even with the Bills, 7-7, with 3:55 to play in the first half.</p>                                <div style="text-align: center">
<div class="iframe">
    <iframe height="310" width="360" src="https://www.wkyc.com/embeds/template/views/modules/datasphere-ad-article/datasphere-ad-article.cshtml" style="border: 2px solid #e6e6e6; padding-left: 20px; padding-top: 20px;"></iframe>
</div> 
                                </div>
<p>Early in the drive, it appeared the Browns had forced the Bills into a punting situation, but an illegal use of the hands penalty gave Buffalo an automatic first down from their own 40-yard line. Nine plays later, the Bills found their way into the end zone.</p><p>Prior to the scoring drive, the Bills had four straight three-and-outs against the Browns’ defense.</p><p><strong>7:46 p.m.-BROWNS TAKE 7-0 LEAD OVER BILLS</strong></p><p>CLEVELAND -- The Cleveland Browns wanted an improved effort from the running game against the Buffalo Bills after a lackluster level of productivity at the New York Giants, and they showed off their hard work on the first drive of the preseason opener at FirstEnergy Stadium.</p><p>Running back Carlos Hyde punctuated the nine-play, 70-yard drive with a four-yard scoring run around right end.</p><div class="article__embed">
    <blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">.<a href="https://twitter.com/elguapo?ref_src=twsrc%5Etfw">@elguapo</a> from 4 yards out ….<br><br>Touchdown, <a href="https://twitter.com/hashtag/Browns?src=hash&ref_src=twsrc%5Etfw">#Browns</a>! <a href="https://twitter.com/hashtag/BUFvsCLE?src=hash&ref_src=twsrc%5Etfw">#BUFvsCLE</a> <a href="https://t.co/jqKZCOan06">pic.twitter.com/jqKZCOan06</a></p>— Cleveland Browns (@Browns) <a href="https://twitter.com/Browns/status/1030601838943322113?ref_src=twsrc%5Etfw">August 17, 2018</a></blockquote><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div><p>Kicker Zane Gonzalez added the extra point, which gave the Browns a 7-0 lead over the Bills with 9:10 to play in the first quarter.</p><p>In addition to the touchdown, Hyde rushed four other times and gained 37 yards, including a 26-yard scamper up the right sideline that took the ball from Cleveland’s 42-yard line out to Buffalo’s 32 just three plays into the drive.</p><div class="article__embed">
    <blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">That stiff arm 👀<br><br>We see you, <a href="https://twitter.com/elguapo?ref_src=twsrc%5Etfw">@elguapo</a>! <a href="https://twitter.com/hashtag/BUFvsCLE?src=hash&ref_src=twsrc%5Etfw">#BUFvsCLE</a> <a href="https://t.co/liLtOBtrfk">pic.twitter.com/liLtOBtrfk</a></p>— Cleveland Browns (@Browns) <a href="https://twitter.com/Browns/status/1030600642195152896?ref_src=twsrc%5Etfw">August 17, 2018</a></blockquote><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div><p>Two plays later, Duke Johnson Jr. rushed for an 18-yard gain before catching a cleat in the grass and falling down while still in full stride up the field.</p><div class="image">
    <div class="image__aspect-ratio-enforcer">
        <div class="image__aspect-ratio-enforced" data-aspect-ratio>
            <img class="image__image" data-asset-fallback="default" data-lazy-loader="https://media.wkyc.com/assets/WKYC/images/585291426/585291426_750x422.jpg" alt="Carlos Hyde-TD Celebration_1534555549438.jpg.jpg" />
        </div>
    </div>
</div>
    <div class="image__caption">Cleveland Browns running back Carlos Hyde, right, celebrates his first-quarter touchdown with running back Duke Johnson (29) and center JC Tretter (64) against the Buffalo Bills at FirstEnergy Stadium in Cleveland.</div>
    <div class="image__credit">Ken Blaze</div>
<p><strong>4:30 p.m.-CLEVELAND BROWNS WANT ‘BETTER EXECUTION, UNDERSTANDING OF SITUATIONAL FOOTBALL’ AGAINST BUFFALO BILLS</strong></p><p>CLEVELAND -- The Cleveland Browns opened the 2018 preseason with a 20-10 victory over the New York Giants at MetLife Stadium in East Rutherford, New Jersey last Thursday night, and will continue the exhibition season against the Buffalo Bills at FirstEnergy Stadium tonight.</p><p>Despite the win, the Browns admittedly have plenty to work on as the regular season approaches, and the coaches are looking for increased productivity and more efficiency against the Bills, a playoff team from a year ago.</p><p>“Let’s see what the second week brings in terms of more execution and understanding situational football,” Browns coach Hue Jackson said after a practice earlier in the week.</p>      <div class="ad ad_border_true ad_position_article_mid5" id="article_mid5_0" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_mid5&quot;,&quot;div&quot;:&quot;article_mid5_0&quot;,&quot;sizes&quot;:[[300,250]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;585176319&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;cTjReTE4PFTtiwNcLwExqbY9&quot;]}}"></div>
<p>“We need to be better at substitutions, getting guys in and out as far as from the sideline. It is Week 2 of the staff being together and understanding what we are trying to accomplish. Those things are important. Obviously, the most important is evaluating the team still.”</p>                                    <div data-module="media-gallery" data-track-off-screen="true" data-track-movement="true">


<div class="media-gallery"
     data-model-id="582225506"
     data-model-section="sports"
     data-model-subsection="nfl"
     data-model-topic="browns"
     data-model-subtopic=""
     data-model-url="/gallery/sports/nfl/browns/photos-cleveland-browns-face-new-york-giants-in-2018-preseason-opener/95-582225506"
     data-model-count="10"
     data-model-assetid="582225506"
     data-model-index="0"
     data-model-targeting="{&quot;pgid&quot;: [&quot;582225506&quot;],&quot;pgtype&quot;: [&quot;&quot;],&quot;strnativekey&quot;: [&quot;cTjReTE4PFTtiwNcLwExqbY9&quot;],&quot;strnativekey&quot;: [&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;]}"
     data-model-autofullscreen="false"
     data-track-off-screen="true">
    <div class="media-gallery__main">
        <div class="media-gallery__title">PHOTOS: Cleveland Browns face New York Giants in 2018 preseason opener</div>
        <div class="media-gallery__fullscreen-toggle"></div>
        <div class="media-gallery__slider-container">
            <div class="media-gallery__slider-arrows">
                <div class="media-gallery__slider-nav media-gallery__slider-nav_direction_previous">
                    <div class="media-gallery__slider-arrow"></div>
                </div>
                <div class="media-gallery__slider-nav media-gallery__slider-nav_direction_next">
                    <div class="media-gallery__slider-arrow"></div>
                </div>
            </div>
            <div class="media-gallery__fake-slider">
                <div class="media-gallery__ratio-enforcer">
                    <div class="media-gallery__ratio-enforced">
                        <img class="media-gallery__fake-slide" src="https://media.wkyc.com/assets/WKYC/images/582224303/582224303_1140x641.jpg" />
                    </div>
                </div>
            </div>
            <div class="media-gallery__slider">
                    <div class="media-gallery__slide"
                         data-index="0"
                         data-model-assetid="582224303"
                         data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%207_1533865268964.jpg_17196497_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224303/582224303_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="1"
                         data-model-assetid="582224395"
                         data-model-caption="Cleveland Browns coach Hue Jackson looks on at the action during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%202_1533865290022.jpg_17197002_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224395/582224395_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="2"
                         data-model-assetid="582224404"
                         data-model-caption="Cleveland Browns running back Nick Chubb (31) is tacked by New York Giants defensive back Andrew Adams (33) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%201_1533865290287.jpg_17197003_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224404/582224404_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="3"
                         data-model-assetid="582224374"
                         data-model-caption="Cleveland Browns tight end David Njoku (85) celebrates his touchdowns with offensive guard Austin Corbett (63) during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%203_1533865284227.jpg_17197001_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224374/582224374_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="4"
                         data-model-assetid="582224359"
                         data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%204_1533865283540.jpg_17196500_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224359/582224359_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="5"
                         data-model-assetid="582224335"
                         data-model-caption="Cleveland Browns wide receiver Rashard Higgins (81) catches the ball in front of New York Giants defensive back Chris Lewis-Harris (39) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%205_1533865275802.jpg_17196499_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224335/582224335_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="6"
                         data-model-assetid="582224320"
                         data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%206_1533865273954.jpg_17196498_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224320/582224320_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="7"
                         data-model-assetid="582223988"
                         data-model-caption="New York Giants quarterback Davis Webb (5) runs from Cleveland Browns defensive end Nate Orchard (44) and defensive end Chris Smith (50) during first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%208_1533865267277.jpg_17196496_ver1.0.jpg"
                         data-model-credit="Noah K. Murray">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582223988/582223988_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="8"
                         data-model-assetid="582223971"
                         data-model-caption="Cleveland Browns tight end David Njoku (85) makes catch for a touchdown against New York Giants defensive backs Chris Lewis-Harris (39) and Leonard Johnson (29) during first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%209_1533865261679.jpg_17196495_ver1.0.jpg"
                         data-model-credit="Noah K. Murray">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582223971/582223971_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="9"
                         data-model-assetid="582223962"
                         data-model-caption="New York Giants running back Saquon Barkley (26) rushes against Cleveland Browns defensive back Damarious Randall (23) during first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%2010_1533865261088.jpg_17196494_ver1.0.jpg"
                         data-model-credit="Noah K. Murray">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582223962/582223962_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
            </div>
        </div>
    </div>
    <div class="media-gallery__secondary">
        <div class="media-gallery__meta">
                <div class="media-gallery__meta-item media-gallery__meta-item_current_true"
                     data-index="0"
                     data-model-assetid="582224303"
                     data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%207_1533865268964.jpg_17196497_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">01</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="1"
                     data-model-assetid="582224395"
                     data-model-caption="Cleveland Browns coach Hue Jackson looks on at the action during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%202_1533865290022.jpg_17197002_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">02</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns coach Hue Jackson looks on at the action during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="2"
                     data-model-assetid="582224404"
                     data-model-caption="Cleveland Browns running back Nick Chubb (31) is tacked by New York Giants defensive back Andrew Adams (33) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%201_1533865290287.jpg_17197003_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">03</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns running back Nick Chubb (31) is tacked by New York Giants defensive back Andrew Adams (33) during the first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="3"
                     data-model-assetid="582224374"
                     data-model-caption="Cleveland Browns tight end David Njoku (85) celebrates his touchdowns with offensive guard Austin Corbett (63) during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%203_1533865284227.jpg_17197001_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">04</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns tight end David Njoku (85) celebrates his touchdowns with offensive guard Austin Corbett (63) during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="4"
                     data-model-assetid="582224359"
                     data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%204_1533865283540.jpg_17196500_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">05</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="5"
                     data-model-assetid="582224335"
                     data-model-caption="Cleveland Browns wide receiver Rashard Higgins (81) catches the ball in front of New York Giants defensive back Chris Lewis-Harris (39) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%205_1533865275802.jpg_17196499_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">06</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns wide receiver Rashard Higgins (81) catches the ball in front of New York Giants defensive back Chris Lewis-Harris (39) during the first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="6"
                     data-model-assetid="582224320"
                     data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%206_1533865273954.jpg_17196498_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">07</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="7"
                     data-model-assetid="582223988"
                     data-model-caption="New York Giants quarterback Davis Webb (5) runs from Cleveland Browns defensive end Nate Orchard (44) and defensive end Chris Smith (50) during first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%208_1533865267277.jpg_17196496_ver1.0.jpg"
                     data-model-credit="Noah K. Murray">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">08</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">New York Giants quarterback Davis Webb (5) runs from Cleveland Browns defensive end Nate Orchard (44) and defensive end Chris Smith (50) during first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="8"
                     data-model-assetid="582223971"
                     data-model-caption="Cleveland Browns tight end David Njoku (85) makes catch for a touchdown against New York Giants defensive backs Chris Lewis-Harris (39) and Leonard Johnson (29) during first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%209_1533865261679.jpg_17196495_ver1.0.jpg"
                     data-model-credit="Noah K. Murray">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">09</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns tight end David Njoku (85) makes catch for a touchdown against New York Giants defensive backs Chris Lewis-Harris (39) and Leonard Johnson (29) during first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="9"
                     data-model-assetid="582223962"
                     data-model-caption="New York Giants running back Saquon Barkley (26) rushes against Cleveland Browns defensive back Damarious Randall (23) during first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%2010_1533865261088.jpg_17196494_ver1.0.jpg"
                     data-model-credit="Noah K. Murray">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">10</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">10</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">New York Giants running back Saquon Barkley (26) rushes against Cleveland Browns defensive back Damarious Randall (23) during first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
        </div>
        <div class="media-gallery__thumbstrip-container">
            <div class="media-gallery__thumbstrip-arrows">
                <div class="media-gallery__thumbstrip-nav media-gallery__thumbstrip-nav_direction_previous">
                    <div class="media-gallery__thumbstrip-arrow"></div>
                </div>
                <div class="media-gallery__thumbstrip-nav media-gallery__thumbstrip-nav_direction_next">
                    <div class="media-gallery__thumbstrip-arrow"></div>
                </div>
            </div>
            <div class="media-gallery__thumbstrip">
                <div class="media-gallery__thumbstrip-mask">
                    <div class="media-gallery__thumbstrip-slider">
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="0"
                                 data-model-assetid="582224303"
                                 data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%207_1533865268964.jpg_17196497_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_true"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224303/582224303_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="1"
                                 data-model-assetid="582224395"
                                 data-model-caption="Cleveland Browns coach Hue Jackson looks on at the action during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%202_1533865290022.jpg_17197002_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224395/582224395_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="2"
                                 data-model-assetid="582224404"
                                 data-model-caption="Cleveland Browns running back Nick Chubb (31) is tacked by New York Giants defensive back Andrew Adams (33) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%201_1533865290287.jpg_17197003_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224404/582224404_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="3"
                                 data-model-assetid="582224374"
                                 data-model-caption="Cleveland Browns tight end David Njoku (85) celebrates his touchdowns with offensive guard Austin Corbett (63) during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%203_1533865284227.jpg_17197001_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224374/582224374_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="4"
                                 data-model-assetid="582224359"
                                 data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%204_1533865283540.jpg_17196500_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224359/582224359_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="5"
                                 data-model-assetid="582224335"
                                 data-model-caption="Cleveland Browns wide receiver Rashard Higgins (81) catches the ball in front of New York Giants defensive back Chris Lewis-Harris (39) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%205_1533865275802.jpg_17196499_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224335/582224335_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="6"
                                 data-model-assetid="582224320"
                                 data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%206_1533865273954.jpg_17196498_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224320/582224320_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="7"
                                 data-model-assetid="582223988"
                                 data-model-caption="New York Giants quarterback Davis Webb (5) runs from Cleveland Browns defensive end Nate Orchard (44) and defensive end Chris Smith (50) during first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%208_1533865267277.jpg_17196496_ver1.0.jpg"
                                 data-model-credit="Noah K. Murray">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582223988/582223988_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="8"
                                 data-model-assetid="582223971"
                                 data-model-caption="Cleveland Browns tight end David Njoku (85) makes catch for a touchdown against New York Giants defensive backs Chris Lewis-Harris (39) and Leonard Johnson (29) during first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%209_1533865261679.jpg_17196495_ver1.0.jpg"
                                 data-model-credit="Noah K. Murray">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582223971/582223971_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="9"
                                 data-model-assetid="582223962"
                                 data-model-caption="New York Giants running back Saquon Barkley (26) rushes against Cleveland Browns defensive back Damarious Randall (23) during first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%2010_1533865261088.jpg_17196494_ver1.0.jpg"
                                 data-model-credit="Noah K. Murray">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582223962/582223962_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="media-gallery__ad">
        </div>
    </div>
</div>
                                    </div>
<p>Jackson feels quarterback play is and will continue to be the biggest difference between the 2018 team and the 2017 squad that finished the regular season with only the second 0-16 record in NFL history, and he got it from both Tyrod Taylor and Baker Mayfield in the win over the Giants.</p><p>Acquired in an offseason trade with the Bills and immediately named the starting quarterback, Taylor, now in his eighth NFL season, completed all five of his passes for 99 yards and one touchdown during his two series against the Giants.</p><p>In his NFL preseason debut, Mayfield found the mark with 11 of his 20 attempts, including seven of the last nine throws, for 212 yards and two touchdowns.</p><p>Taylor and the Browns’ first-team offense is expected to play more against the Bills, who helped lead to the AFC Playoffs last year.</p><p>“Obviously, I want to see them play longer than they played last week -- a quarter or whatever that is, maybe a little longer,” Jackson said of the first-team offense and defense. “It all depends on how it is going. I definitely want them out there longer than eight plays. If the results are touchdowns, we will keep going. We just need to play a little bit more.”</p>                                    <div data-module="media-gallery" data-track-off-screen="true" data-track-movement="true">


<div class="media-gallery"
     data-model-id="582324927"
     data-model-section="sports"
     data-model-subsection="nfl"
     data-model-topic="browns"
     data-model-subtopic=""
     data-model-url="/gallery/sports/nfl/browns/photos-cleveland-browns-qbs-tyrod-taylor-baker-mayfield-have-solid-showings-in-win-at-new-york/95-582324927"
     data-model-count="6"
     data-model-assetid="582324927"
     data-model-index="0"
     data-model-targeting="{&quot;pgid&quot;: [&quot;582324927&quot;],&quot;pgtype&quot;: [&quot;&quot;],&quot;strnativekey&quot;: [&quot;cTjReTE4PFTtiwNcLwExqbY9&quot;],&quot;strnativekey&quot;: [&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;]}"
     data-model-autofullscreen="false"
     data-track-off-screen="true">
    <div class="media-gallery__main">
        <div class="media-gallery__title">PHOTOS: Cleveland Browns QBs Tyrod Taylor, Baker Mayfield have solid showings in win at New York</div>
        <div class="media-gallery__fullscreen-toggle"></div>
        <div class="media-gallery__slider-container">
            <div class="media-gallery__slider-arrows">
                <div class="media-gallery__slider-nav media-gallery__slider-nav_direction_previous">
                    <div class="media-gallery__slider-arrow"></div>
                </div>
                <div class="media-gallery__slider-nav media-gallery__slider-nav_direction_next">
                    <div class="media-gallery__slider-arrow"></div>
                </div>
            </div>
            <div class="media-gallery__fake-slider">
                <div class="media-gallery__ratio-enforcer">
                    <div class="media-gallery__ratio-enforced">
                        <img class="media-gallery__fake-slide" src="https://media.wkyc.com/assets/WKYC/images/582327294/582327294_1140x641.jpg" />
                    </div>
                </div>
            </div>
            <div class="media-gallery__slider">
                    <div class="media-gallery__slide"
                         data-index="0"
                         data-model-assetid="582327294"
                         data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball as offensive guard Spencer Drango (66) blocks New York Giants defensive tackle Damon Harrison (98) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2014_1533906291462.jpg_17198952_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327294/582327294_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="1"
                         data-model-assetid="582327679"
                         data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) scrambles as New York Giants linebacker Jordan Williams (79) pursues during the second half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2011_1533906305237.jpg_17198955_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327679/582327679_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="2"
                         data-model-assetid="582327603"
                         data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2013_1533906293405.jpg_17198953_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327603/582327603_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="3"
                         data-model-assetid="582327618"
                         data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) attempts to pass against the New York Giants during second half at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2012_1533906298802.jpg_17198954_ver1.0.jpg"
                         data-model-credit="Noah K. Murray">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327618/582327618_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="4"
                         data-model-assetid="582224303"
                         data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%207_1533865268964.jpg_17196497_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224303/582224303_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
                    <div class="media-gallery__slide"
                         data-index="5"
                         data-model-assetid="582224359"
                         data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                         data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%204_1533865283540.jpg_17196500_ver1.0.jpg"
                         data-model-credit="Vincent Carchietta">
                        <div class="media-gallery__ratio-enforcer">
                            <div class="media-gallery__ratio-enforced">
                                <img class="media-gallery__image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224359/582224359_1140x641.jpg" />
                            </div>
                        </div>
                    </div>
            </div>
        </div>
    </div>
    <div class="media-gallery__secondary">
        <div class="media-gallery__meta">
                <div class="media-gallery__meta-item media-gallery__meta-item_current_true"
                     data-index="0"
                     data-model-assetid="582327294"
                     data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball as offensive guard Spencer Drango (66) blocks New York Giants defensive tackle Damon Harrison (98) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2014_1533906291462.jpg_17198952_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">01</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">06</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Tyrod Taylor (5) throws the ball as offensive guard Spencer Drango (66) blocks New York Giants defensive tackle Damon Harrison (98) during the first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="1"
                     data-model-assetid="582327679"
                     data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) scrambles as New York Giants linebacker Jordan Williams (79) pursues during the second half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2011_1533906305237.jpg_17198955_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">02</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">06</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Baker Mayfield (6) scrambles as New York Giants linebacker Jordan Williams (79) pursues during the second half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="2"
                     data-model-assetid="582327603"
                     data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2013_1533906293405.jpg_17198953_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">03</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">06</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="3"
                     data-model-assetid="582327618"
                     data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) attempts to pass against the New York Giants during second half at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2012_1533906298802.jpg_17198954_ver1.0.jpg"
                     data-model-credit="Noah K. Murray">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">04</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">06</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Baker Mayfield (6) attempts to pass against the New York Giants during second half at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="4"
                     data-model-assetid="582224303"
                     data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%207_1533865268964.jpg_17196497_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">05</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">06</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
                <div class="media-gallery__meta-item media-gallery__meta-item_current_false"
                     data-index="5"
                     data-model-assetid="582224359"
                     data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                     data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%204_1533865283540.jpg_17196500_ver1.0.jpg"
                     data-model-credit="Vincent Carchietta">
                    <div class="media-gallery__slide-counter">
                        <span class="media-gallery__current-slide">06</span>
                        <span class="media-gallery__slide-counter-divider">/</span>
                        <span class="media-gallery__slide-count">06</span>
                    </div>
                    <div class="media-gallery__caption dot-ellipsis dot-height-40">Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey.</div>
                    <div class="media-gallery__sharing">
                        <a data-tracking="sharing/twitterLink" class="media-gallery__icon media-gallery__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank"></a>
                        <div class="media-gallery__icon media-gallery__icon_type-facebook"></div>
                    </div>
                </div>
        </div>
        <div class="media-gallery__thumbstrip-container">
            <div class="media-gallery__thumbstrip-arrows">
                <div class="media-gallery__thumbstrip-nav media-gallery__thumbstrip-nav_direction_previous">
                    <div class="media-gallery__thumbstrip-arrow"></div>
                </div>
                <div class="media-gallery__thumbstrip-nav media-gallery__thumbstrip-nav_direction_next">
                    <div class="media-gallery__thumbstrip-arrow"></div>
                </div>
            </div>
            <div class="media-gallery__thumbstrip">
                <div class="media-gallery__thumbstrip-mask">
                    <div class="media-gallery__thumbstrip-slider">
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="0"
                                 data-model-assetid="582327294"
                                 data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball as offensive guard Spencer Drango (66) blocks New York Giants defensive tackle Damon Harrison (98) during the first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2014_1533906291462.jpg_17198952_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_true"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327294/582327294_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="1"
                                 data-model-assetid="582327679"
                                 data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) scrambles as New York Giants linebacker Jordan Williams (79) pursues during the second half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2011_1533906305237.jpg_17198955_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327679/582327679_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="2"
                                 data-model-assetid="582327603"
                                 data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) rushes with the ball as New York Giants defensive end Kerry Wynn (72) pursues during the first half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2013_1533906293405.jpg_17198953_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327603/582327603_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="3"
                                 data-model-assetid="582327618"
                                 data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) attempts to pass against the New York Giants during second half at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/10/Browns-Giants%2012_1533906298802.jpg_17198954_ver1.0.jpg"
                                 data-model-credit="Noah K. Murray">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582327618/582327618_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="4"
                                 data-model-assetid="582224303"
                                 data-model-caption="Cleveland Browns quarterback Tyrod Taylor (5) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%207_1533865268964.jpg_17196497_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224303/582224303_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                            <div class="media-gallery__thumbstrip-slide"
                                 data-index="5"
                                 data-model-assetid="582224359"
                                 data-model-caption="Cleveland Browns quarterback Baker Mayfield (6) throws the ball during the first half against the New York Giants at MetLife Stadium in East Rutherford, New Jersey."
                                 data-model-url="http://content.wkyc.com/photo/2018/08/09/Browns-Giants%204_1533865283540.jpg_17196500_ver1.0.jpg"
                                 data-model-credit="Vincent Carchietta">
                                <div class="media-gallery__ratio-enforcer">
                                    <div class="media-gallery__ratio-enforced">
                                        <div class="media-gallery__thumbstrip-selection media-gallery__thumbstrip-selection_visible_false"></div>
                                        <img class="media-gallery__thumbstrip-image" data-custom-lazy-loader="https://media.wkyc.com/assets/WKYC/images/582224359/582224359_360x203.jpg" />
                                    </div>
                                </div>
                            </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="media-gallery__ad">
        </div>
    </div>
</div>
                                    </div>
<p>Regardless of how many plays the Browns’ coaches give the first-team players, they are hoping to see an increased sense of urgency and more efficiency in the operation of the game because it will give Jackson and his staff a better evaluation of the talent on the roster.</p><p>“There is always urgency anytime we are playing for our players because they are putting something on tape that we get to evaluate and say a guy is not playing as well as he should or we have to do a better job of coaching the players,” Jackson said.</p><p>“I think there is urgency all throughout our football team. Obviously, there is competition at some spots, and that is going to sort itself out by the way we play. Guys will play. Next week is the dress-rehearsal game. We will continue to evaluate in that game, as well.”</p><p><strong>FOLLOW ALONG</strong></p><p>For the latest information during the preseason home opener against the Bills and to be a part of the discussion, tweet using the hashtag, #3Browns.</p><p><a class="twitter-timeline" data-widget-id="963850622784163842" href="https://twitter.com/hashtag/3Browns">#3Browns Tweets</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></p><p>Stream Live <a href="https://www.fubo.tv/lp/football/?bgvideo=nfldraftlp.mp4&title=Watch%20the%202018%20NFL%20Draft%20on%20NFL%20Network&subinfo=Follow%20all%20the%20picks.%20Get%20all%20the%20analysis.&priceline=Stream%20on%20your%20TV%20and%20other%20devices&irad=472637&irmp=1219249&utm_source=WKYC_NFL&utm_campaign=WKYC">with fuboTV -Try Free Trial</a></p>                    <div class="copyright">&#169; 2018 WKYC</div>

        </div>
    </div>
        <div id="taboola-below-article-thumbnails-2nd-0" data-model-page-type="article" data-model-ad="below_taboola" data-model-mode="thumbnails-h2" data-model-targetType="mix" data-model-placement="Below Article Thumbnails 2nd" data-model-url="http://www.wkyc.com/article/sports/nfl/browns/recap-cleveland-browns-fall-to-buffalo-bills-19-17-in-preseason-home-opener/95-585176319" class="taboola"></div>

    </div>
</div>
                                                    </div>
                                                </div>
                                        </div>

                        </div>
                    </div>
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                                        <div class="grid__gutter-module" data-module="sticky-sharing">
<div class="sticky-sharing">
    <a data-tracking="sharing/twitterLink" class="sticky-sharing__icon sticky-sharing__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank">
    </a>
    <div class="sticky-sharing__icon sticky-sharing__icon_type-facebook"></div>

</div>                                        </div>
                        </div>
                    </div>
                </div>
            </div>
            <div class="grid__section-group grid__section-group_theme_default">



                <div class="grid__section grid__section_sticky_none grid__section_theme_default grid__section_theme-changed_false grid__section_previous-theme_default grid__section_next-theme_default" data-theme="default" data-next-theme="default" data-previous-theme="default">
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                        </div>
                    </div>
                    <div class="grid__content grid__content_theme_default grid__content_theme-changed_false">
                        <div class="grid__main grid__main_sticky_none">
                                        <div class="grid__cell grid__cell_columns_3" data-starting-column="1" data-columns="12">

                                                <div class="grid__module grid__module_ready_true" data-track-movement="false" data-count="0" data-module="ad" data-module-id="2d60ed3a-b39c-4bca-9d4c-a1dbd607e57f">
                                                    <div class="grid__throbber"></div>
                                                    <div class="grid__module-inner grid__module-inner_ready_true">
      <div class="ad ad_border_true ad_position_article_flex_btf" id="article_flex_btf" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_flex_btf&quot;,&quot;div&quot;:&quot;article_flex_btf&quot;,&quot;sizes&quot;:[[970,250],[728,90],[1140,286],[1,1]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;585176319&quot;],&quot;main_front&quot;:[&quot;false&quot;],&quot;pgtype&quot;:[&quot;article&quot;]}}"></div>

                                                    </div>
                                                </div>
                                        </div>

                        </div>
                    </div>
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                        </div>
                    </div>
                </div>
            </div>
</div>

            </div>
        </div>
            <div class="page__footer">
<div class="footer">
    <div class="footer__inner">
        <div class="footer__social">

<div class="social">
    <ul class="social__list social__list_align_center">
        <li class="social__item">
            <a class="social__link" target="_blank" href="https://www.facebook.com/WKYC.Channel3">
                <span class="social__icon social__icon_type_facebook"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="17" height="16" viewBox="0 0 17 16">
    <image id="Vector_Smart_Object" data-name="Vector Smart Object" width="17" height="16" xlink:href="data:img/png;base64,iVBORw0KGgoAAAANSUhEUgAAABEAAAAQCAQAAABaOFzUAAAABGdBTUEAALGPC/xhBQAAACBjSFJNAAB6JgAAgIQAAPoAAACA6AAAdTAAAOpgAAA6mAAAF3CculE8AAAAAmJLR0QAAKqNIzIAAAAJcEhZcwAACxIAAAsSAdLdfvwAAAAHdElNRQfhAhENOQMc/E5OAAAAlklEQVQoz73PMQtBARTF8d+ToiyGV4oSWQ0+gEL5GL6Ewax8G5OdwWozyOYVC4MimwmTAe+xOdu9/e895wSzjZpvioLZ3Q+lY7cHY3s5PbV4ZKnjAhpJyNBFoKuknGS0Rsv0OaZikBvySXHPRjhhpY+BIq+ldyovJ0fh+5esNhauQnUZ4adRwRxVW02Tb3Hf9Eck+kFED4KVHWZAZTHbAAAAAElFTkSuQmCC" />
</svg></span>
            </a>
        </li>

        <li class="social__item">
            <a class="social__link" target="_blank" href="https://twitter.com/intent/user?screen_name=@WKYC">
                <span class="social__icon social__icon_type_twitter"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="19" height="16" viewBox="0 0 19 16">
    <image id="Vector_Smart_Object" data-name="Vector Smart Object" width="19" height="16" xlink:href="data:img/png;base64,iVBORw0KGgoAAAANSUhEUgAAABMAAAAQCAQAAABezYzpAAAABGdBTUEAALGPC/xhBQAAACBjSFJNAAB6JgAAgIQAAPoAAACA6AAAdTAAAOpgAAA6mAAAF3CculE8AAAAAmJLR0QAAKqNIzIAAAAJcEhZcwAACxIAAAsSAdLdfvwAAAAHdElNRQfhAhENNjO9vWItAAABFUlEQVQoz33QPUhbARAA4O89k4qDXRrMIrgFwSkuLlJSea3oVoRu4i4IHerk5Jyhi44uDg4KHS3tg9JBLLQFaSQVERGh0EBpJHFQNJYOJs0PTW66n2+4uyDmkd/aIy1vTr/Pln2Scx3Egw49ddKCHvoiU89vlVVNhDJG7JtsYYv/EElpJa9CVaR89FqqPsp1rHBuNYg5MgquvLGrYN3jNjYU/QritCkbBnSPZFRLGLLlrgcqRTVCRd/19WB7EPpjQaUHe3vP+GrJjy6oYqfByBruwvLRZZOtePdf9E3+PgnrH5sxq9iBfnruppU9EHlprA2deuKsUYReOHDhvWct5M6arONmI2HbB/OmjUsJlBXENjsv/wvGUENgDcdadwAAAABJRU5ErkJggg==" />
</svg></span>
            </a>
        </li>


    </ul>
</div>
        </div>
        <div class="footer__menu">
            <ul class="footer__list">
                <li class="footer__item"><a class="footer__link" href="/terms">Terms of Service</a></li>
                <li class="footer__item"><a class="footer__link" href="/privacy">Privacy Notice</a></li>
                <li class="footer__item"><a class="footer__link" href="/privacy">Your California Privacy Notice</a></li>
                <li class="footer__item"><a class="footer__link" href="/adchoices">Ad Choices</a></li>
                        <li class="footer__item"><a class="footer__link" href="http://content.wkyc.com/document_dev/2018/05/23/Cleveland_OH_EEO_Public_File_2017 -2018_16005487_ver1.0.pdf">EEO Public File Report</a></li>
                        <li class="footer__item"><a class="footer__link" href="/fcc-public-inspection-file">FCC Online Public Inspection File </a></li>
                        <li class="footer__item"><a class="footer__link" href="/closed-captioning">Closed Captioning Procedures</a></li>
            </ul>
        </div>
        <div class="footer__copyright">
            &copy; 2018 WKYC-TV. All Rights Reserved.
        </div>
    </div>
</div>
      <div class="ad ad_border_true ad_position_exit_interstitial" id="exit_interstitial" data-model-refresh="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;exit_interstitial&quot;,&quot;div&quot;:&quot;exit_interstitial&quot;,&quot;sizes&quot;:[[1,1]]}}"></div>
            </div>
        <script src="/scripts/require.js"></script>
        <script>

        (function() {
            var modules = [
                'error',
                'page',
                'grid',
                'desktop-header',
                'toolbar',
                'weather-summary',
                'navigation',
                'video',
                'throbber',
                'utils',
                'fitted-headline',
                'forecast',
                'article',
                'continuous-scroll',
                'sharing',
                'gallery',
                'radar-gallery',
                'forecast',
                'article-crosspromo',
                'featured-videos',
                'chapter-slider',
                'pollen',
                'olympics-live-stream',
                'three-day-outlook',
                'current-weather',
                'search-results',
                'tracking',
                'chapter-progress',
                'progress',
                'countdown-clock',
                'longform-explore',
                'media-gallery',
                'social-sharing',
                'weather-alerts',
                'weather-interactive-radar',
                'closings',
                'tealium',
                'alert-bar',
                'cookie',
                'sticky-sharing',
                'live-indicator',
                'sharethrough',
                'taboola',
                'elections',
                'just-for-you',
                'just-for-you-li',
                'olympics-tv-listings',
                'headline-list-with-abstract',
                'text-only-headline-list',
                'story-snapshot-with-abstract',
                'snapshot',
                'story-snapshot',
                'special-content-headline-list',
                'notfound',
                'linked-image',
                'article-recirculation',
                'linked-image-with-title',
                'newsletter-signup',
                'linked-image-with-title',
                'newsletter-signup-multiple',
                'live-videos',
                'breaking-news',
                'weather-alerts',
                'closings',
                'media-gallery-alt',
                'alert-center-menu',
                'trending-list',
                'toc',
                'featured-radars'
            ];
            require.config({
                'baseUrl': '/',
                'deps': modules,
                'waitSeconds': 30,
                'bundles': {
                    'modules': modules
                },
                'paths': {
                    'jquery': 'scripts/jquery-3.1.1',
                    'jwplayer': 'content/player/jwplayer.js?version=2.19.0',
                    'modules': 'Views/dist/scripts/modules.min.js?version=2.19.0',
                    'facebook': 'https://connect.facebook.net/en_US/all',
                    'twitter': 'https://platform.twitter.com/widgets',
                    'slick': 'content/libs/slick/slick.min',
                    'dotdotdot': 'content/libs/dotdotdot/jquery.dotdotdot.min',
                    'jqueryui': 'Views/lib/jquery-ui/jquery-ui.min',
                    'comscore': 'content/libs/comscore/comscore.min',
                    'stickyfill': 'content/libs/stickyfill/stickyfill.min'
                },
                'shim': {
                    'facebook': {
                        'exports': 'FB'
                    },
                    'twitter': {
                        'exports': 'twttr'
                    },
                    'jwplayer': ['jquery'],
                    'jqueryui': {
                        'deps': ['jquery']
                    },
                    'slick': ['jquery'],
                    'dotdotdot': ['jquery']
                }
            });
        })();
        </script>
                    <script type="text/javascript">
                        console.log('ttaboola-in-script');
                        window._taboola = window._taboola || [];
                        _taboola.push({ home: 'auto' });
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)) {
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'),
                            document.getElementsByTagName('script')[0],
                            '//cdn.taboola.com/libtrc/tegna-network1/loader.js',
                            'tb_loader_script');
                        if (window.performance && typeof window.performance.mark == 'function') { window.performance.mark('tbl_ic'); }
                    </script>

        <script type="text/javascript" src="//cloudfront.loggly.com/js/loggly.tracker-latest.min.js" async></script>
        <noscript>
            <style>
                .grid__module {
                    height: auto;
                    opacity: 1;
                }
            </style>
        </noscript>
    </body>
</html>
